如何将WRTnode2R/2P设置为有线路由器

From WRTnode Wiki
Jump to: navigation, search

将WRTnode2R其中一个网口设置为wan口

硬件、软件特性

硬件:

  • WRTnode2R默认底板上网口分别是port1(靠近miniusb口)和port2。默认都是lan口

Lan1.jpg
软件:

  • WRTnode2R sdk默认port1,port2,port3,port4为lan口;port0为wan口
  • wwan默认是作为apcli0

软件操作

WRTnode2R sdk默认port1,port2,port3,port4为lan口,port1为wan,wwan默认是作为apcli0,如下:

vim /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd4:8263:c49c::/48'

config interface 'lan'
        option ifname 'eth0.1
        option force_link '1'
        option macaddr '64:51:7e:80:35:ee'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.8.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.2'
        option force_link '1'
        option macaddr '64:51:7e:80:35:ef'
        option proto 'dhcp'

config interface 'wwan'
        option ifname 'apcli0'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'                     //1代表eth0.1,从上面的定义eth0.1对应'lan'
        option ports '1 2 3 4 6t'           //1 2 3 4分别对应port1 port2 port3 port4 ;6t是指mt7628内置交换机

config switch_vlan
        option device 'switch0'
        option vlan '2'                   //2对应eth0.2,从上面的定义eth0.2对应'wan'
        option ports '0 6t'               //0对应port0

受硬件限制(底板上只有port1和port2),需将port1和port2其中一个设置为wan口。如下是将port1设置为wan口,port0为lan口:
network其他部分代码不变:

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 3 4 6t'         //port0设置为lan

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'             //port0设置为wan

修改完之后,保存退出,重启network

/etc/init.d/network restart

硬件操作

需要一根网线,一头接在WRTnode2R的port1(靠近miniusb口的网口),一头接在已连入外网的路由器的lan口上。
是否分配到ip:
1:http://192.168.8.1进入luci
2:进入 Network -> Interfaces
LanToWan1.png

可以看到wan,wwan分配到ip地址。
这时我们用pc,手机等wifi设备连上WRTnode2R的wifi,已经可以上网啦